https://github.com/domProjects/CI-AdminLTE

application Update main_sidebar.php 1 month ago
assets [UPD] AdminLTE 2.3.11 1 year ago
install disable error with stdClass::$bgcolor 7 months ago
system update codeigniter 3.1.10 7 months ago
upload First commit 3 years ago
.gitattributes :octocat: Added .gitattributes & .gitignore files 3 years ago
.gitignore disable error with stdClass::$bgcolor 7 months ago
.htaccess Add security XSS, Frame, Sniff, ... 3 years ago
README.md add demo link 7 months ago
index.php [UPD] CodeIgniter 3.1.7 1 year ago
install.php Add alert file exist >> install.php 3 years ago
robots.txt [MOD] Base site URL and add installation method 1 year ago
sitemap.xml [MOD] Base site URL and add installation method 1 year ago
README.md

CI-AdminLTE

CodeIgniter 3.1.10 with AdminLTE 2.3.11

Installation

  1. Unzip the package.
  2. Upload the CI-AdminLTE folders and files to your server. Normally the index.php file will be at your root.
  3. Open the application/config/common/dp_config.php file with a text editor and set your base URL: ``` // Fill in the file of your project here when you develop locally. $host_dev = 'CI-AdminLTE';

// Fill in the domain name here when your project is online. // Example : www.johndoe.com // johndoe.com $host_prod = 'your_domain.tld'; ```

  1. Create a table named ci_adminlte and inject the data from the install/sql/ci_adminlte.sql file.
  2. Change if necessary the connection information to your database in the application/config/database.php file.

Demo

https://demo.domprojects.com/ci-adminlte/auth/login

Login

  • Email : admin@admin.com / Password : password

Browser Compatibility

Support for most major browsers including Chrome, Firefox, IE9+, Opera and Safari.

Languages

  • English
  • French
  • Portuguese (translation by marcelod)
  • ... and more soon

Server Requirements

PHP version 5.6 or newer is recommended.

It should work on 5.4.8 as well, but we strongly advise you NOT to run such old versions of PHP, because of potential security and performance issues, as well as missing features.

Dependencies

NAME VERSION WEB REPO
CodeIgniter 3.1.10 Website Github
AdminLTE 2.3.11 Website Github
Bootstrap 3.3.7 Website Github
Ion Auth 2.6.0 Website Github
jQuery 2.2.4 Website Github
Font Awesome 4.7.0 Website Github
Mobile Detect 2.8.30 Website Github

CodeIgniter 3 Documentation

Reference